python版本引起的错误ImportError: No module named ‘httplib’ ‘lib2’

1. 报错 No module named ‘newspaper’   改成  import newspaper   或from newspaper

但是安装包的时候需要 安装名为 pip3 install newspaper3k

 

2. 报错No module named ‘md5’   改成  import hashlib

 

3.报错: No module named ‘urllib2’

import urllib 改成 import urllib.request

4.解决办法:

  • 首先看一下自己使用的python版本,python2 和 python3 处理的方法不同
  • python2解决办法,加上如下代码,
  • 1
    2
    3
    import sys
    reload(sys)
    sys.setdefaultencoding(‘utf-8’)

     

  • python3解决办法,加上如下代码,
  • 1
    2
    import importlib,sys
    importlib.reload(sys)#使用时候改成这样
5.import httplib 改成 import http.client
.原因:Python 2.x中的"httplib"模块在Python 3.x中变成了"http.client"
原代码:
复制代码
import httplib
import urllib

reqheaders={
'MobileType':'Android',
'DeviceToken':'xxxxxxxxx',
'OSVersion':'1.0.3',
'AppVersion':'14',
'Host':'192.xxx.x.xxxx'}  

reqconn=httplib.HTTPConnection("192.xxx.x.xxxx")
reqconn.request("GET", "/Login?username=1416&password=123", None, reqheaders)
res=reqconn.getresponse()
print res.status,  res.reason
print res.msg
print res.read()
复制代码

修改后代码:

复制代码
import http.client    #修改引用的模块
import urllib

reqheaders={
'MobileType':'Android',
'DeviceToken':'xxxxxxxxx',
'OSVersion':'1.0.3',
'AppVersion':'14',
'Host':'192.xxx.x.xxxx'}  

reqconn=http.client.HTTPConnection("192.xxx.x.xxxx")  #修改对应的方法
reqconn.request("GET", "/Login?username=1416&password=123", None, reqheaders)
res=reqconn.getresponse()
print (res.status,  res.reason)
print (res.msg)
print (res.read())
复制代码

未经允许不得转载:萌萌Apprentissage » python版本引起的错误ImportError: No module named ‘httplib’ ‘lib2’

赞 (0) 打赏

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏

//下一个脚本特效